wordpress 5.0屏蔽Gutenberg编辑器恢复TinyMCE的方法

WordPress 5.0屏蔽Gutenberg编辑器恢复TinyMCE的方法

随着WordPress 5.0版本的发布,新的Gutenberg编辑器成为了默认编辑器。虽然Gutenberg编辑器带来了很多新的功能,但是许多WordPress用户还是更喜欢传统的TinyMCE编辑器。

方法一:使用插件

  1. 前往WordPress后台,点击插件 -> 添加新插件。
  2. 在搜索框中输入“Classic Editor”,然后点击搜索。
  3. 找到“Classic Editor”插件,点击安装,然后点击启用。
  4. 完成安装后,您应该能够看到TinyMCE编辑器已经恢复了。

方法二:在主题的functions.php文件中添加代码

如果不想使用插件,则可以通过添加代码来恢复TinyMCE编辑器。在这之前,需要备份一下您的主题的functions.php文件。

  1. 进入WordPress后台,点击外观 -> 编辑器。
  2. 在右侧选择您要编辑的主题。如果您使用的是子主题,则选择子主题。
  3. 找到functions.php文件并点击进去。
  4. 在文件结尾加入以下代码:

add_filter('use_block_editor_for_post', '__return_false');

添加代码后,保存functions.php文件即可生效。如果需要还原,请将备份的functions.php文件重新覆盖回去。

希望本文可以帮助您恢复TinyMCE编辑器,让您更加方便地进行文章编辑和发布。

晓白博客网版权所有,原文地址https://www.xbnb.cn/5385
© 版权声明
THE END
喜欢就支持一下吧
点赞0 分享
评论 抢沙发

请登录后发表评论

    请登录后查看评论内容